Had to add http://www.bitesms.com/cydia/beta5.0 as a Cydia source to get this. 4.99 didn't work with iOS 4.1 jailbroken.